app.thatch.com Outage
Resolved·Full outage

Our vendor identified the issue and has resolved it

Fri, Dec 5, 2025, 09:17 AM
(1 day ago)
·
Affected components
App
Updates

Resolved

Our vendor identified the issue and has resolved it

Fri, Dec 5, 2025, 09:17 AM

Investigating

We are aware of an outage with our primary vendors and are investigating.

Fri, Dec 5, 2025, 09:00 AM(17 minutes earlier)