App is down
Resolved·Full outage

We have identified and fixed the problem.

Fri, Nov 21, 2025, 07:20 AM
(2 weeks ago)
·
Affected components
App
Updates

Resolved

We have identified and fixed the problem.

Fri, Nov 21, 2025, 07:20 AM

Investigating

We're investigating an outage for the Thatch app.

Fri, Nov 21, 2025, 06:27 AM(53 minutes earlier)