App unavailable due to a Cloudflare outage
Resolved·Full outage

Service has been restored and Cloudflare is reporting that all systems are operating normally.

Tue, Nov 18, 2025, 07:14 PM
(2 weeks ago)
·
Affected components
App
Updates

Resolved

Service has been restored and Cloudflare is reporting that all systems are operating normally.

Tue, Nov 18, 2025, 07:14 PM

Monitoring

The Thatch app is now available. We are continuing to monitor the progress of the upstream incident. Feel free to reach out to support@thatch.com if you continue to experience any issues.

Tue, Nov 18, 2025, 03:49 PM(3 hours earlier)

Monitoring

Some users are still reporting intermittent issues. We are continuing to monitor the progress of the upstream incident.

Tue, Nov 18, 2025, 03:08 PM(41 minutes earlier)

Monitoring

The upstream provider has fixed the issue and service is restored. We are continuing to monitor to ensure that service remains restored.

Tue, Nov 18, 2025, 02:51 PM(17 minutes earlier)

Monitoring

Service is restored for some users. We are continuing to monitor the upstream outage and service for users.

Tue, Nov 18, 2025, 02:41 PM

Identified

The upstream provider outage is still ongoing (https://www.cloudflarestatus.com/incidents/8gmgl950y3h7). We are awaiting mitigations to restore service.

Tue, Nov 18, 2025, 02:25 PM(16 minutes earlier)

Investigating

The Thatch app is unavailable due to an ongoing upstream cloud provider outage. We are investigating ways to restore service.

Tue, Nov 18, 2025, 01:42 PM(42 minutes earlier)